<!DOCTYPE html>
<html lang="fr">
<head>
	<meta charset="utf-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<title>Comment développer des applications robustes et flexibles ?</title>
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<!-- stylesheets -->
	<title>Document</title>
	<link href='https://fonts.googleapis.com/css?family=Droid+Serif:400,700,400italic,700italic%7COpen+Sans:400italic,700italic,400,700' rel='stylesheet' type='text/css'>
	<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato:300,400,700,300italic,400italic,700italic">
    <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Orbitron">
    <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Source+Sans+Pro">
	<link rel="stylesheet" href="/assets/css/bootstrap.min.css?v=c68fe2808e">
	<link rel="stylesheet" href="/assets/css/font-awesome.min.css?v=c68fe2808e">
	<link rel="stylesheet" href="/assets/css/style.css?v=c68fe2808e">
	<link rel="stylesheet" type="text/css" href="/assets/css/hl-styles/monokai_sublime.css?v=c68fe2808e">
	<link rel="stylesheet" type="text/css" href="/assets/css/screen.css?v=c68fe2808e">

	<link rel="stylesheet" type="text/css" href="/assets/css/prism-themes/prism-vscode-dark.css?v=c68fe2808e">
	
	<script>
  var disqus_shortname = 'itexpert';
</script>
    <meta name="description" content="L’architecture d’une application est EXTRÊMEMENT importante. Mal faite, elle peut totalement ruiner un projet. Mais comment peut-on éviter ça ?" />
    <link rel="shortcut icon" href="/favicon.png" type="image/png" />
    <link rel="canonical" href="https://itexpert.fr/blog/principe-ouvert-ferme/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    <link rel="amphtml" href="https://itexpert.fr/blog/principe-ouvert-ferme/amp/" />
    
    <meta property="og:site_name" content="IT Expert" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Comment développer des applications robustes et flexibles ?" />
    <meta property="og:description" content="L’architecture d’une application est EXTRÊMEMENT importante. Mal faite, elle peut totalement ruiner un projet. Mais comment peut-on éviter ça ?" />
    <meta property="og:url" content="https://itexpert.fr/blog/principe-ouvert-ferme/" />
    <meta property="og:image" content="https://itexpert.fr/content/images/2020/11/MiniatureBase-1.png" />
    <meta property="article:published_time" content="2020-11-15T10:00:00.000Z" />
    <meta property="article:modified_time" content="2021-01-06T21:14:34.000Z" />
    <meta property="article:tag" content="SOLID" />
    <meta property="article:tag" content="Architecture" />
    
    <meta property="article:publisher" content="https://www.facebook.com/ghost" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="Comment développer des applications robustes et flexibles ?" />
    <meta name="twitter:description" content="L’architecture d’une application est EXTRÊMEMENT importante. Mal faite, elle peut totalement ruiner un projet. Mais comment peut-on éviter ça ?" />
    <meta name="twitter:url" content="https://itexpert.fr/blog/principe-ouvert-ferme/" />
    <meta name="twitter:image" content="https://itexpert.fr/content/images/2020/11/MiniatureBase-1.png" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Léo DRIAT" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="SOLID, Architecture" />
    <meta name="twitter:site" content="@tryghost" />
    <meta name="twitter:creator" content="@ITExpertFr" />
    <meta property="og:image:width" content="1920" />
    <meta property="og:image:height" content="605" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "IT Expert",
        "url": "https://itexpert.fr/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://itexpert.fr/content/images/2020/06/logofull.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Léo DRIAT",
        "image": {
            "@type": "ImageObject",
            "url": "https://itexpert.fr/content/images/2020/04/logo.png",
            "width": 2160,
            "height": 2160
        },
        "url": "https://itexpert.fr/blog/author/leo/",
        "sameAs": [
            "http://itexpert.fr",
            "https://twitter.com/ITExpertFr"
        ]
    },
    "headline": "Comment développer des applications robustes et flexibles ?",
    "url": "https://itexpert.fr/blog/principe-ouvert-ferme/",
    "datePublished": "2020-11-15T10:00:00.000Z",
    "dateModified": "2021-01-06T21:14:34.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://itexpert.fr/content/images/2020/11/MiniatureBase-1.png",
        "width": 1920,
        "height": 605
    },
    "keywords": "SOLID, Architecture",
    "description": "L’architecture d’une application est EXTRÊMEMENT importante. Mal faite, elle peut totalement ruiner un projet. Mais comment peut-on éviter ça ?",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://itexpert.fr/"
    }
}
    </script>

    <meta name="generator" content="Ghost 3.13" />
    <link rel="alternate" type="application/rss+xml" title="IT Expert" href="" />
    <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/tocbot/4.12.0/tocbot.min.css" integrity="sha512-SFw7k74K3983tyOlJIHa8atr9Ppef3Kix5cmifwzU7ZdtU2E0FRuOVRtd3ENpMJ8sNCie5hlb/0j23efcdQJXA==" crossorigin="anonymous" />
<script defer data-domain="itexpert.fr" src="https://plausible.itexpert.fr/js/plausible.js"></script>
</head>
<body class="post-template tag-solid tag-architecture">
	<header>
	<nav class="navbar navbar-default">
		<div class="container">
			<div class="navbar-header">
				<!-- start logo -->
				<a class="logo image-logo navbar-brand" href="https://itexpert.fr"><img src="/content/images/2020/06/logofull.png" alt="IT Expert"></a>
				<!-- end logo -->
			</div>
			<div id="navbar" class="navbar-collapse navbar-right collapse">
	<ul class="nav navbar-nav">
		<li class="blog "><a href="https://itexpert.fr/blog/">Blog</a></li>
		<li class="a-propos "><a href="https://itexpert.fr/a-propos/">À Propos</a></li>
		<li class="videos "><a href="https://www.youtube.com/channel/UCMIJTZQ0-h-3ixe0hYrYh7Q">Vidéos</a></li>
		<li class="rss "><a href="https://itexpert.fr/blog/rss/">RSS</a></li>
	</ul>
</div>
		</div>
	</nav>
</header>
	    
<div class="main-content-wrap">
	<div class="container">
		<div class="row">
            <aside class="col-md-3 sidebar aside-left">
	<div class="follow-scrollbar">
		<div class="widget">
	<h4 class="title">Suivez-moi !</h4>
	<div class="content social">
		<a href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fplatform.twitter.com%2F&ref_src=twsrc%5Etfw&region=follow_link&screen_name=ITExpertFr&tw_p=followbutton">
			<button class="btn btn-primary button-twitter"><i class="fa fa-twitter"></i> @ITExpertFr</button>
		</a>
	</div>
</div>
		<div class="widget">
	<h4 class="title">Partagez !</h4>
	<div class="share-wrap-inner clearfix">
		<ul>
			<li>
				<a href="https://www.facebook.com/sharer/sharer.php?u=Comment développer des applications robustes et flexibles ? https://itexpert.fr/blog/principe-ouvert-ferme/" onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;"><i class="fa fa-facebook"></i></a>
			</li>
			<li>
				<a href="https://twitter.com/share?url=Comment développer des applications robustes et flexibles ? https://itexpert.fr/blog/principe-ouvert-ferme/ par @ITExpertFr" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;"><i class="fa fa-twitter"></i></a>
			</li>
			<li>
				<a href="http://reddit.com/submit?url=Comment développer des applications robustes et flexibles ? https://itexpert.fr/blog/principe-ouvert-ferme/" onclick="window.open(this.href, 'reddit-share', 'width=490,height=530');return false;"><i class="fa fa-reddit"></i></a>
			</li>
			<li>
				<a href="http://www.linkedin.com/shareArticle?mini=true&url=Comment développer des applications robustes et flexibles ? https://itexpert.fr/blog/principe-ouvert-ferme/" onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;"><i class="fa fa-linkedin"></i></a>
			</li>
		</ul>
	</div>
</div>	</div>
</aside>			<div class="col-12 col-lg-6">
				<article class="post-wrap single">
                    <div class="featured-media cover">
                        <img src="https://itexpert.fr/content/images/2020/11/MiniatureBase-1.png" alt="Comment développer des applications robustes et flexibles ?">
                    </div>
                    <div class="post-content post-body">
                        <h1 class="post-title">Comment développer des applications robustes et flexibles ?</h1>
                        <div class="post-meta">
                            <span class="author">
                                <i class="fa fa-user"></i>
                                <a href="/blog/author/leo/">Léo DRIAT</a>
                            </span>
                            <span class="date">
                                <i class="fa fa-calendar-o"></i>
                                nov. 15, 2020
                            </span>
                            <span class="comment">
                                <i class="fa fa-comment-o"></i>
                                <a href="/blog/principe-ouvert-ferme/#commento"></a>
                            </span>
                        </div>
                        <div class="single-post-entry">
                            <p><em>Cet article fait partie d'une série sur SOLID : les 5 principes fondamentaux de la programmation. <a href="https://itexpert.fr/blog/tag/solid/">Vous pouvez retrouver tous les autres ici.</a></em></p><!--kg-card-begin: html--><aside class="toc"></aside><!--kg-card-end: html--><hr><p>Commençons par une petite histoire. Un peintre est chargé de repeindre le sol d’une cuisine.</p><p>Tout semble bien se passer, mais à la fin, il se rend compte qu’il s’est mis dans une situation un peu embarrassante : il s’est accidentellement coincé dans le coin de la pièce, et il ne peut plus revenir à l’entrée sans marcher sur la peinture fraîche.</p><!--kg-card-begin: markdown--><p>Le pauvre peintre est alors confronté à un dilemme :</p>
<ul>
<li>Revenir à la porte d’entrée, et donc refaire le travail qu’il vient de terminer.</li>
<li>Détruire le mur pour sortir de la pièce.</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/78483211.jpg" class="kg-image"></figure><p>Absurde, n’est-ce pas ? Et pourtant, <strong><strong>cette situation se produit absolument TOUT LE TEMPS en dans les projets informatiques.</strong></strong></p><p>Reprenons depuis le début, un développeur est chargé de créer une application pour un client.</p><p>Tout semble bien se passer, mais à la fin, il se rend compte qu’il s’est mis dans une situation un peu embarrassante : il a accidentellement par développé un système tellement rigide et peu extensible qu’il ne peut plus rien modifier sans tout casser.</p><!--kg-card-begin: markdown--><p>Le pauvre développeur est alors confronté à un dilemme :</p>
<ul>
<li><a href="https://fr.wikipedia.org/wiki/R%C3%A9usinage_de_code">Réusiner</a> le système, et donc refaire le code qu’il vient de terminer.</li>
<li>Détruire le <a href="https://fr.wikipedia.org/wiki/Architecture_logicielle">design de son application</a> pour apporter ses modifications.</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://itexpert.fr/content/images/2020/11/jenga-488252207.png" class="kg-image"><figcaption>Après quelques mois, certaines applications ont tendance à ressembler à ça...</figcaption></figure><p>Dans le cas du peintre, on est d’accord que casser le mur est une solution complètement irréaliste. Ça ne viendrait à l’idée de personne de faire ça.</p><p>Et pourtant, dans le cas du développeur, <strong><strong>c’est généralement la solution privilégiée</strong></strong>, car les conséquences sont plus subtiles. Cependant, elles sont tout aussi désastreuses.</p><p>Les anglais ont une expression parfaite pour illustrer ça : <strong><em><em><strong>to code yourself into a corner.</strong></em></em></strong></p><blockquote><em><em>Ce n’est pas du tout comparable. Le client final, il ne les voit pas les trous dans le design d’une application, contrairement au propriétaire de la cuisine.</em></em></blockquote><p>Certes, il ne les voit pas directement, mais quand les délais de livraison atteindront systématiquement un mois de retard, que l’équipe de développement aura sombré dans l’alcoolisme et que la quantité de bugs sera comparable à celle d’un produit Microsoft, ça risque de l’emmerder.</p><p>C’est un effet papillon : une petite cassure dans le design d’une application aujourd’hui peut entraîner des jours de maintenance plus tard. C’est ce que l’on appelle <strong><strong>la dette technique.</strong></strong></p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/technical_debt-1474889472699.png" class="kg-image"></figure><p>Mais pourquoi la plupart des projets finissent comme ça ? Et comment éviter la catastrophe sans devoir tout réécrire ? On va voir ça plus en détail.</p><blockquote>Besoin d'un résumé des principes SOLID et leur application concrète ? <strong><u><a href="https://itexpert.fr/blog/resume-application-solid">Allez lire le bonus de cet article</a></u></strong>. </blockquote><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h2 id="probl-me">Problème</h2><p>Aujourd’hui, à l’époque des <a href="https://fr.wikipedia.org/wiki/M%C3%A9thode_agile">méthodes agiles</a>, tous les projets informatiques se déroule de la manière suivante : <strong><strong>des besoins se présentent, et on apporte des solutions au fur et à mesure.</strong></strong></p><p>Typiquement, on a une exigence (fonctionnalité, <a href="https://fr.wikipedia.org/wiki/R%C3%A9cit_utilisateur">récit utilisateur</a>, correction de bug…), on la développe, on la teste et on la déploie. C’est un fonctionnement pratique, car rapide et répétable à l’infini.</p><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://itexpert.fr/content/images/2020/11/zeze.png" class="kg-image"><figcaption>Une itération typique sur un projet agile.</figcaption></figure><p>De la même manière, lorsqu’une exigence change, on la modifie dans le code, on la teste et on la redéploie. A priori, aucun souci.</p><p><strong><strong>Et pourtant, c’est là que les choses se gâtent.</strong></strong></p><p>Car très souvent, les développeurs sont pris par surprise avec une exigence qui en contredit une autre déployée 3 mois auparavant.</p><p>Ils doivent donc revenir en arrière pour modifier le module (classe, fonction...) de l’ancienne exigence, ce qui peut avoir des conséquences dramatiques.</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><p>Tout d’abord, cela risque d’amener à une <strong><strong>violation du </strong><u><strong><a href="https://itexpert.fr/blog/principe-responsabilite-unique/">principe de responsabilité unique (SRP)</a></strong></u><strong>.</strong></strong></p><p>En effet, si un module a été pensé pour ne faire qu’une seule chose, il est peu probable qu’une nouvelle exigence vienne simplement changer son comportement (sauf s’il s’agit d’un bug). Typiquement, elle demandera d’ajouter un truc en plus.</p><p>Par exemple, au jour J : <em><em>le peintre doit préparer son matériel avant d’aller sur place.</em></em></p><pre><code class="language-csharp">public void PrepareForWork(PaintingMission mission)
{
    GatherPaint(mission.paintNeeded);
    GatherTools(mission.toolsNeeded);
    PutIniform();
}</code></pre><p>J+3 mois : <em><em>ah oui, au fait, on aimerait que si le peintre n’a pas le matériel nécessaire, il appelle le client pour décaler les travaux.</em></em></p><pre><code class="language-csharp">public void PrepareForWork(PaintingMission mission)
{
    // 1er responsabilité : vérification
    if(PaintAvailable(mission.paintNeeded) &amp;&amp; ToolsAvailable(mission.toolsNeeded))
    {
        // 2nd responsabilité : préparation
        GatherPaint(mission.paintNeeded);
        GatherTools(mission.toolsNeeded);
        PutIniform();
    }
    else
    {
        // 3eme responsabilité : annulation
        CallClient();
    }
}</code></pre><p>Erreur fatale, car le module fait maintenant 3 choses : préparer le matériel, vérifier que tout y est et appeler le client. C’est une violation du SRP.</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><p>Mais pire, c’est que <strong><strong>chaque modification sur un module met en danger toutes ses dépendances</strong></strong>, car celles-ci pourraient ne plus être compatibles avec la dernière version.</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/DependancesCorruption.png" class="kg-image"></figure><p>Laissez-moi vous illustrer ça avec une anecdote personnelle.</p><p>J’étais en train de construire une bibliothèque de fonctions pour mon entreprise commune à tous les projets <u><a href="https://itexpert.fr/blog/boite-a-outils/">(cf. mon article sur la boite à outils)</a></u>.</p><p>J’avais fait une fonction IsEmpty(object) qui permettait simplement de vérifier si une donnée provenant de la base était considérée comme “vide” (NULL ou "").</p><figure class="kg-card kg-code-card"><pre><code class="language-csharp">public static bool IsEmpty(object obj)
{
    if (obj == null) return true;
    if (obj is string &amp;&amp; object == "") return true;
    return false;
}</code></pre><figcaption>Notez que l'idée n'était pas bonne de base, j'aurais dû séparer ça en deux sous-fonctions.</figcaption></figure><p>Mais en l’utilisant dans une autre application, je me suis rendu compte que ma fonction ne marchait pas.</p><p>En effet, le framework du projet avait une valeur spéciale pour désigner un NULL venant d’une base de données, qui n’était ni NULL, ni "" (BDNull.Value pour les connaisseurs de .NET).</p><p>Qu'à cela ne tienne ! J’ai modifié ma fonction pour qu’elle prenne en compte cette valeur dans la condition.</p><pre><code class="language-csharp">public static bool IsEmpty(object obj)
{
    if (obj == null) return true;
    if (obj is string &amp;&amp; object == "") return true;
    if (obj == DBNull.Value) return true;
    return false;
}</code></pre><p>Cool, le code fonctionne dans la nouvelle application, problème résolut ! Sauf que quand mon collègue a voulu compiler l’ancienne, plus rien ne fonctionnait.</p><p><strong><strong>J’avais accidentellement bombardé toutes les applications qui dépendaient de cette bibliothèque.</strong></strong></p><p>Autant vous dire que je ne l’ai fait qu’une fois, pas deux.</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h2 id="solution">Solution</h2><p>Donc, au final, on a besoin de modifier un module parce qu’une exigence le demande. Mais en faisant ça, on risque de casser le design de l’application et de mettre en danger tout le programme. Comment faire ?</p><p>Et bien justement, on ne modifie rien ! C’est le <strong><strong>principe ouvert/fermé</strong></strong> : un module doit être ouvert à l’extension, mais fermé à la modification.</p><p>Autrement dit, une fois qu’un module est prêt pour la production, <strong><strong>on y touche plus jamais. Toutes les modifications se font à l’extérieur</strong></strong> pour que le cœur reste toujours EXACTEMENT le même.</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/Extension.png" class="kg-image"></figure><!--kg-card-begin: markdown--><p>Ce principe est absolument fondamental, car il permet de rendre une codebase beaucoup plus :</p>
<ul>
<li><strong>Flexible</strong> : tous vos modules sont extensibles, donc vous n’êtes jamais bloqué dans le coin.</li>
<li><strong>Robuste</strong> : en ne faisant qu’étendre un module, vous ne mettez jamais en danger ses dépendances.</li>
</ul>
<!--kg-card-end: markdown--><p>Et plus vos modules sont abstraits (frameworks, bibliothèques…), plus ce principe devient obligatoire, car plus il y a de chances qu’une modification ruine absolument tout.</p><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://itexpert.fr/content/images/2020/11/DependancesErreurCatastrophe.png" class="kg-image"><figcaption>Catastrophe !</figcaption></figure><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h2 id="explication">Explication</h2><blockquote><em><em>Ok dans la théorie, mais dans les faits, ça a l’air plus casse-tête qu’autre chose...</em></em></blockquote><p>Je ne vous cache pas que ce principe est plus subtil que le SRP, cependant, tout devient plus clair quand on comprend les implications des deux concepts.</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h3 id="ferm-la-modification">Fermé à la modification</h3><p>Une fois qu’un module est prêt à la production, on y touche plus, même quand les exigences changent.</p><p><strong><strong>Cela signifie</strong></strong> <strong><strong>qu’avant de mettre un module en production, il doit être impeccable.</strong></strong> Une fois qu’il commence à avoir des dépendances, c’est terminé.</p><!--kg-card-begin: markdown--><p>Cela implique des tests :</p>
<ul>
<li>Unitaires : module indépendant du reste.</li>
<li>D’intégration : module assemblé avec le reste.</li>
<li>De non-régression : est-ce qu’il ne casse pas autre chose dans le programme ? C’est un pléonasme car si le principe ouvert/fermé est correctement respecté, il ne devrait y avoir AUCUNE régression, jamais.</li>
<li>Fonctionnels et métiers : est-ce qu’il correspond parfaitement aux exigences telles qu’elles ont été demandées ?</li>
</ul>
<!--kg-card-end: markdown--><p>Vous remarquerez que, comme pour le SRP, la méthode du <a href="https://fr.wikipedia.org/wiki/Test_driven_development">développement piloté par des tests (TDD)</a> est encore une fois très pertinente.</p><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://itexpert.fr/content/images/2020/11/TDD_Global_Lifecycle.png" class="kg-image"><figcaption>Illustration de Wikipedia</figcaption></figure><p>Et bien sûr, le code du module doit aussi être propre et réusiné aux petits oignons. Il faut prendre son temps et ne pas faire de déploiements impulsifs, même si c’est tentant ! Bref, ne pas faire comme moi 😖</p><blockquote><em><em>Mais ce n’est pas un peu long de faire tout ça ?</em></em></blockquote><p>C’est ce que je suis dit quand j’ai découvert ce principe pour la première fois. <em><em>C’est quoi ce truc de barbu, j’ai pas que ça à foutre, j’ai une famille à nourrir !</em></em></p><p>Mais mon expérience, ainsi que celle de développeurs beaucoup plus balèzes que moi, m’ont appris que<strong><strong> le temps investi dans la création des modules est ridicule par rapport au temps perdu à maintenir une codebase complètement ruinée.</strong></strong></p><p>Pour le peintre, il est plus facile de repeindre complètement le sol de la pièce plutôt que de reconstruire la maison.</p><blockquote><em><em>Et comment faire si on a merdé ?</em></em></blockquote><p>Malheureusement, il peut arriver qu’une situation imprévue (typiquement, un cas non testé) cause des problèmes après un passage en production. Dans ce cas, pas le choix, il faut modifier le module de l’intérieur.</p><p><strong><strong>Mais c’est la seule exception ! </strong></strong>Et c’est justement pour ça que vous devez avoir un panel de tests de non-régression solide et prêts à être exécutés une fois la modification faite.</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h3 id="ouvert-l-extension">Ouvert à l’extension</h3><p>Si un module a besoin d’une modification, elle doit être faite de l’extérieur.</p><p>Imageons ça avec une petite allégorie. <strong><strong>Votre application est arbre</strong></strong>, avec un tronc, des branches, et des brindilles.</p><p>Si vous avez fait pousser un bel arbre, avec des belles branches, vous devriez avoir des belles brindilles. Ces brindilles sont les seules choses qui intéressent le client. <strong><strong>Ce sont les règles métier</strong></strong>.</p><p>Le reste de l’arbre aura pour seul et unique but d’accueillir et de faire de la place pour ces brindilles. Et pour avoir un bel arbre, <strong><strong>il faut abstraire un maximum de code.</strong></strong></p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/Abstraction.png" class="kg-image"></figure><p>Que le peintre ai à faire le mur, le sol ou le plafond, dans tous les cas, il devra peindre.</p><p>Qu’il ai à faire le sol de votre cuisine, d’un bar ou du palais de l’Élysée, dans tous les cas, il doit peindre le sol.</p><!--kg-card-begin: markdown--><p>Si vous faites un module dédié à tout le processus de la peinture du sol de votre cuisine, vous vous tirez une balle dans le pied, car le jour où le peintre devra faire autre chose, vous serez bloqué dans le coin :</p>
<ul>
<li>Soit vous modifiez le module pour correspondre aux nouvelles exigences, et vous violez le principe ouvert/fermé, ainsi que le SRP (la totale).</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-code-card"><pre><code class="language-csharp">public PaintFloor(Location location)
{
    PrepareForWork();
    GoToLocation(location);
    PrepareRoom(location);

    if(location is Bar)
    {
        // ...
    }
    else if(location is Kitchen) 
    {
        // ...
    }
    // ...
    // Et ça peut continuer encore longtemps
}
</code></pre><figcaption>Généralement, quand vous avez une série de if… else if… ou un énorme switch, c’est que vous avez merdé quelque part.</figcaption></figure><!--kg-card-begin: markdown--><ul>
<li>Soit vous faites un nouveau module, ce qui amène à beaucoup de duplication de code (<a href="https://fr.wikipedia.org/wiki/Ne_vous_r%C3%A9p%C3%A9tez_pas">DRY</a>).</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-code-card"><pre><code class="language-csharp">public PaintFloorKitchen(Kitchen location)
{
    PrepareForWork();
    GoToLocation(location);
    PrepareRoom(location);
    // ...
}

public PaintFloorBar(Bar location)
{
    PrepareForWork();
    GoToLocation(location);
    PrepareRoom(location);
    // ...
}

public PaintFloorElysée(Elysee location)
{
    PrepareForWork();
    GoToLocation(location);
    PrepareRoom(location);
    // ...
}</code></pre><figcaption>Pareil, si la majorité de votre code est copié-collé, c’est qu’il a un gros souci.</figcaption></figure><p>En abstrayant votre code, vous pourrez faire peindre n’importe quoi au peintre sans modifier ni dupliquer vos modules.</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/ExtensionPlusPlus.png" class="kg-image"></figure><p>Cela demande de toujours avoir une longueur d’avance sur les exigences, afin de <strong><strong>prévoir de l’espace pour le futur.</strong></strong></p><!--kg-card-begin: markdown--><p>Je dois vous avouer que ce n’est pas facile. Cependant, certains détails dans les exigences doivent vous mettre la puce à l’oreille :</p>
<ul>
<li>Il y a X TYPES de… : 80% du temps, il y en aura plus que le nombre annoncé.</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-code-card"><pre><code class="language-csharp">class Paint { /*...*/ }
class AcrylicPaint : Paint { /*...*/ }
class GlyceroPaint : Paint { /*...*/ }
// On reserve de la place au cas où il y aurait d'autres types.</code></pre><figcaption>Il y a <b><strong>deux types de peinture</strong></b> : la peinture à l’eau et la peinture à l’huile.</figcaption></figure><!--kg-card-begin: markdown--><ul>
<li>Il faut VERBE un NOM : un module pour le verbe, un module pour le nom.</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-code-card"><pre><code class="language-csharp">// Nom
class Paint { /*...*/ }

// Nom
class Painter 
{
    // Verbe
    public MixPaint(Paint paint1, Paint paint2) { /*...*/ }
}</code></pre><figcaption>Il faut que le <b><strong>peintre </strong></b>puisse <b><strong>mélanger </strong></b>deux <b><strong>peintures</strong></b>.</figcaption></figure><!--kg-card-begin: markdown--><ul>
<li>Il faut faire tel ACTION sous tel CONDITION : celui-ci est fourbe, car on a tendance à mélanger les deux. Mais bien souvent, la condition peut s’appliquer à d’autres actions, et l’action peut avoir plusieurs conditions.</li>
</ul>
<!--kg-card-end: markdown--><figure class="kg-card kg-code-card"><pre><code class="language-csharp">// La peinture
class Paint { /*...*/ }

// Les travaux
class PaintingMission 
{
    public Paint PaintNeeded { get; private set; }
    public Painter Worker { get; private set; }

    // Action
    public void PostponeMission() { /*...*/ }

    // Assemblage Condition/Action
    public static void PostponeMissionIfPaintUnavailable()
    {
        if(!Worker.IsPaintAvailable(PaintNeeded))
            this.Postpone();
    }
}

// Le peintre
class Painter
{
    private List&lt;Paint&gt; PaintAvailable { get; set; }

    // Condition
    public bool IsPaintAvailable(Paint paint) 
    {
        return PaintAvailable.Where(x =&gt; x.Type == paint.Type &amp;&amp; x.Color == paint.Color).Count &gt; 0
    }
}</code></pre><figcaption>Il faut que le <b><strong>peintre décale </strong></b>les travaux <b><strong>S’IL</strong></b> n’a plus de <b><strong>peinture</strong></b>.</figcaption></figure><p>Tout ça relève plus de l’analyse du cahier des charges, un sujet qui mérite son propre article à lui tout seul.</p><p>La seule chose à retenir, c’est qu’il ne faut jamais se contenter de ce qui est écrit, <strong><strong>et toujours réfléchir hors de la boite.</strong></strong></p><blockquote><em><em>Mais au final est-ce que ce n’est pas une violation du principe <a href="https://fr.wikipedia.org/wiki/YAGNI">YAGNI</a> ?</em></em></blockquote><p>Techniquement, si. Vous pouvez créer un module très ouvert et ne pas vous en servir.</p><p>Si le peintre ne peint QUE des sols de cuisine, alors les couches PaintFloor et PaintFloorKitchen peuvent sembler redondantes…</p><p><strong><strong>Mais ce n’est pas ABSOLUMENT PAS une excuse pour ne pas les faire</strong></strong>, déjà parce que ça ne prend pas plus de temps, mais surtout parce que vous ne pouvez jamais être certain de l’avenir.</p><p>Et s’il décide subitement de se reconvertir en peintre de plafonds de bars ? Vous ne savez pas. Donc, dans le doute, programmez toujours ouvert.</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h2 id="application">Application</h2><!--kg-card-begin: markdown--><p>Récapitulons, pour appliquer le principe ouvert/fermé, il faut faire deux choses :</p>
<ul>
<li><strong>Chouchouter ses modules</strong> avec des tests et du réusinage tout en respectant les bonnes pratiques, de manière à ne plus jamais y retoucher après la mise en production.</li>
<li><strong>Créer des couches d’abstraction</strong> de manière à rendre le programme flexible, peu importe les nouvelles exigences.</li>
</ul>
<!--kg-card-end: markdown--><p>Pour le premier point, <u><a href="https://itexpert.fr/blog/principe-responsabilite-unique/">je vous renvoie vers mon article sur le principe de responsabilité unique (SRP)</a></u>, car tout y est expliqué. Ici, je vais uniquement traiter le second point.</p><p>Il y a tellement de manières d’abstraire des modules que je pourrais écrire un livre rien que sur ça. En voici quelques-unes :</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h3 id="types-abstraits">Types abstraits</h3><p>C’est la méthode que l’inventeur des principes SOLID, Robert C. Martin (l’oncle Bob) a utilisé pour décrire le principe ouvert/fermé.</p><!--kg-card-begin: markdown--><p>Elle reprend l’idée de l’arbre que j’ai utilisée au-dessus :</p>
<ul>
<li><strong>Des types abstraits</strong>, qui contiennent des règles génériques. Ils sont destinés à être utilisés par d’autres types (abstraits ou non).</li>
<li><strong>Des règles métiers</strong>, qui héritent des règles génériques tout en contenant leurs propres règles. Elles sont destinées à être utilisées directement par l’utilisateur final.</li>
</ul>
<!--kg-card-end: markdown--><p>Le résultat donne lieu à un enchaînement de couches d’abstraction évolutif à l’infini. Vous pouvez ajouter des modules en dessous, au-dessus, et même entre deux.</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/OCPPeinture.png" class="kg-image"></figure><pre><code class="language-csharp">class Paint { /*...*/ }

class PaintFloor : Paint { /*...*/ }
class PaintCeiling : Paint { /*...*/ }
class PaintWalls : Paint { /*...*/ }

class PaintFloorKitchen : PaintFloor { /*...*/ }
class PaintFloorBar : PaintFloor { /*...*/ }
class PaintFloorElysee : PaintFloor { /*...*/ }

// Extensible à l'infinie</code></pre><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h3 id="injection-de-d-pendances">Injection de dépendances</h3><p>C’est un principe qui dit que les dépendances d’un module doivent toujours être construites et injectées de l’extérieur.</p><p>En gros, si vous avez une classe qui est composée de l’instance d’une autre classe, au lieu de l’initialiser dans le constructeur, vous faites ça à l’extérieur et vous la passez toute cuite.</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/InjectionDeDependances.png" class="kg-image"></figure><pre><code class="language-csharp">Painter joseThePainter = new Painter();
Paint acrylicBluePaint = new Paint();
PaintingMission paintTheKitchenFloor = new PlanningMission(joseThePainter, acrylicBluePaint);</code></pre><p>Cela permet de créer des modules plus flexibles, car vous avez un contrôle total sur les données qui vont servir à initialiser la classe, tout en conservant le principe d’encapsulation. C’est tout bénef !</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h3 id="d-corateurs">Décorateurs</h3><p>C’est une stratégie qui consiste à venir ajouter dynamiquement des responsabilités à un module sans briser le SRP, car tout se fait de l’extérieur.</p><blockquote><em><em>Mais quelle différence avec le polymorphisme ?</em></em></blockquote><p>La différence, c’est que le polymorphisme permet de créer une sous-classe, alors qu’un décorateur permet <strong><strong>d’ajouter une option à une classe existante</strong></strong>.</p><p>Là où le polymorphisme vous permet de définir un objet de tel ou tel sous-type, les décorateurs permet de définir un objet qui va contenir <strong><strong>telles et telles caractéristiques</strong></strong>.</p><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://itexpert.fr/content/images/2020/11/400px-Decorator_UML_class_diagram.svg.png" class="kg-image"><figcaption>Illustration de Wikipedia</figcaption></figure><p>Pour le coup, comme le code est assez fat, <a href="https://fr.wikipedia.org/wiki/D%C3%A9corateur_(patron_de_conception)">je vous renvoie vers Wikipedia qui montre plein d’exemples dans plein de langages différents</a>. Je ferais sûrement un article intégralement dédié au sujet tant je le trouve fascinent !</p><!--kg-card-begin: html--><br/><!--kg-card-end: html--><h3 id="architecture-fonctionnelle">Architecture fonctionnelle</h3><p>Bien que le principe ouvert/fermé est généralement associé à la POO, celui-ci s’applique tout aussi bien, voir encore mieux, à la <u><a href="https://itexpert.fr/blog/programmation-fonctionnelle/">programmation fonctionnelle (PF)</a></u>.</p><p>Tout d’abord, la composition de fonctions permet de chaîner des modules pour créer des comportements différents. Ainsi, vous pouvez modifier les données à l’entrée et à la sortie d’une fonction sans avoir à la modifier.</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/PFComposition.png" class="kg-image"></figure><pre><code class="language-csharp">public static Paint GetColoredPaint(string hexColor) { }

public static ColoredPaint MixPaint(Paint paint1, Paint paint2) { }

public static DryPaint DryPaint(Paint paint) { }

public static void Main(string[] args)
{
    // On laisse sécher
    DryPaint dryPurplePaint = DryPaint(
        // Mélange rouge + bleu = violet
        MixPaint(
            // Peinture rouge
            GetColoredPaint("0000FF"),
            // Peinture bleue
            GetColoredPaint("FF0000")
        )
    )
}</code></pre><p>Encore plus fort, les fonctions d’ordre supérieur permettent de passer des fonctions en paramètre d’autres fonctions, et donc de modifier leur comportement interne, mais de l’extérieur !</p><figure class="kg-card kg-image-card"><img src="https://itexpert.fr/content/images/2020/11/PFHigherOrderFunction.png" class="kg-image"></figure><pre><code class="language-csharp">public record Paint
{
    public int Quantity { get; }
    public string Color { get; }

    public Paint(int quantity) =&gt; (Quantity) = (quantity);
}

public static int Add(List&lt;object&gt; list, Func&lt;object, int&gt; action) 
{
    int res = 0;
    foreach(int item in list)
    {
        res += action(item);
    }
    return res;
}

public static void Main(string[] args)
{
    var list = new List&lt;Paint&gt;() { new Paint(5), new Paint(6), new Paint(10) };
    var paintQuantity = Add(list, x =&gt; x.Quantity); // 21
    var paintQuantity = Add(list, x =&gt; x.Quantity &gt; 8 ? 8 : x.Quantity); // 19
}</code></pre><p>Et bien que cela semble hors sujet, il est tout à fait possible de mixer PF et POO dans un seul programme, afin de tirer le meilleur des deux mondes.</p><p>J’explique tout dans <u><a href="https://itexpert.fr/blog/programmation-fonctionnelle/">mon article sur la programmation fonctionnelle</a></u>, ainsi que dans <u><a href="https://itexpert.fr/blog/scala/">celui sur Scala</a></u>. Qui sait, peut-être qu’ils vont révolutionner votre manière de coder 😉</p><hr><p>Voilà pour le principe ouvert/fermé, un concept un peu intimidant, mais absolument primordial pour designer des codebases bien huilée.</p><p>Souvenez-vous qu’en programmation, <strong><strong>les efforts d’aujourd’hui vous récompenseront demain.</strong></strong> Donc ne faites pas comme ce peintre, et prévoyez vos coups d’avance (et ne touchez pas à ce p***** de mur).</p><!--kg-card-begin: markdown--><p>Aller, encore une fois pour que ça rentre 😋</p>
<ul>
<li>Travaillez vos modules à 100% avant de les mettre en production (robuste).</li>
<li>Laissez toujours une porte ouverte pour étendre vos modules (flexible).</li>
</ul>
<!--kg-card-end: markdown--><p>Le principe de substitution de Liskov (Liskov Substitution Principle) correspond au L de SOLID : un ensemble de 5 concepts fondamentaux pour construire des applications maintenables, pérennes et évolutives.</p><p><u><a href="https://itexpert.fr/blog/tag/solid/">Vous pouvez retrouver tous mes autres articles sur SOLID ici.</a></u> Ils ont tous pour but de vous faire découvrir ces principes et leur importance primordiale.</p><p>Mais pour résumé et une application concrète des principes SOLID dans un vrai programme, <strong><u><a href="https://itexpert.fr/blog/resume-application-solid">allez lire le bonus de cet article</a></u></strong>. </p><!--kg-card-begin: markdown--><p>Et pour les gens qui raffolent d’architecture logicielle et de bonnes pratiques, voici d’autres articles qui vont vous intéresser :</p>
<ul>
<li><a href="https://itexpert.fr/blog/concepts-fondamentaux-poo/">5 concepts fondamentaux de la POO.</a></li>
<li><a href="https://itexpert.fr/blog/programmation-fonctionnelle/">La programmation fonctionnelle démystifiée : pourquoi et comment ?</a></li>
<li><a href="https://itexpert.fr/blog/querybuilder/">Simplifiez vos requêtes SQL grâce à la programmation orientée objets.</a></li>
</ul>
<!--kg-card-end: markdown--><p>Quant à moi, je vous laisse, il faut que j’aille pêcher un silure dans mon étang, ça fait 3 mois que j’essaye de l’avoir et je commence à perdre patience. Je vous donne rendez-vous la semaine prochaine pour un nouvel article sur le blog des développeurs ultra-efficaces !</p><hr><p>Accéder au bonus : <strong><a href="https://itexpert.fr/blog/resume-application-solid">Résumé et application des principes SOLID.</a></strong></p>
                        </div>
                        <div class="tag-list">
                            <i class="fa fa-tag fa-fw"></i>
                            <a href="/blog/tag/solid/">SOLID</a>, <a href="/blog/tag/architecture/">Architecture</a>
                        </div>
                    </div>
                </article>
                <div class="share-wrap">
	<div class="share-wrap-inner clearfix">
		<div class="share-text">Soutenez-moi en partageant cet article 💙:</div>
		
		<ul>
			<!-- facebook -->
		<li>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https://itexpert.fr/blog/principe-ouvert-ferme/" onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;"><i class="fa fa-facebook"></i></a>
		</li>
		<!-- twitter -->
		<li>
			<a href="https://twitter.com/share?text=Comment%20d%C3%A9velopper%20des%20applications%20robustes%20et%20flexibles%20%3F&amp;url=https://itexpert.fr/blog/principe-ouvert-ferme/" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;"><i class="fa fa-twitter"></i></a>
		</li>
		<!-- reddit -->
		<li>
			<a href="http://reddit.com/submit?url=https://itexpert.fr/blog/principe-ouvert-ferme/&title=Comment développer des applications robustes et flexibles ?" onclick="window.open(this.href, 'reddit-share', 'width=490,height=530');return false;"><i class="fa fa-reddit"></i></a>
		</li>
		<!-- linkedin -->
		<li>
			<a href="http://www.linkedin.com/shareArticle?mini=true&url=https://itexpert.fr/blog/principe-ouvert-ferme/" onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;"><i class="fa fa-linkedin"></i></a>
		</li>		
	</div>
</div>                
<div class="comment-container">
	<script defer src="https://commento.itexpert.fr/js/commento.js"></script>
	<script>
	window.commentoCustomText = function(count) {
		if(count < 2) {
			return count + " Commentaire";
		} else {
			return count + " Commentaires";
		}
	}
	</script>
	<script defer src="https://commento.itexpert.fr/js/count.js" data-custom-text="window.commentoCustomText"></script>

	<p>Afin d'éviter les spams, messages haineux ou insultants envers les autres commentateurs, <b>les commentaires sont soumis à modération</b></p>
	<div id="commento"></div>
	<noscript>Activez JavaScript pour pouvoir accéder à la section commentaires.</noscript>
</div>

			</div>
			<aside class="col-md-3 sidebar aside-right">
	<!-- start widget -->
<div class="widget">
	<h4 class="title">Articles Récents</h4>
	<div class="content recent-post">
			<div class="recent-single-post">
				<a href="/blog/critique-manifeste-agile-3/" class="post-title">Une critique du manifeste Agile. (3/3)</a><div class="date">juillet 04, 2021</div>
			</div>
			<div class="recent-single-post">
				<a href="/blog/critique-manifeste-agile-2/" class="post-title">Une critique du manifeste Agile. (2/3)</a><div class="date">juin 27, 2021</div>
			</div>
			<div class="recent-single-post">
				<a href="/blog/critique-manifeste-agile/" class="post-title">Une critique du manifeste Agile. (1/3)</a><div class="date">juin 20, 2021</div>
			</div>
			<div class="recent-single-post">
				<a href="/blog/mise-en-place-standards/" class="post-title">Comment instaurer des standards de code (sans se faire d&#x27;ennemis) ?</a><div class="date">juin 13, 2021</div>
			</div>
	</div>
</div>
<!-- end widget -->	<div class="widget">
    <h4 class="title">Catégories</h4>
    <div class="content tag-cloud">
        <a href="/blog/tag/architecture/">Architecture</a><a href="/blog/tag/bonnes-pratiques/">Bonnes pratiques</a><a href="/blog/tag/comparaisons/">Comparaisons</a><a href="/blog/tag/conseils/">Conseils</a><a href="/blog/tag/critique/">Critique</a><a href="/blog/tag/design-pattern/">Design Pattern</a><a href="/blog/tag/devops/">DevOps</a><a href="/blog/tag/non-technique/">Non-technique</a><a href="/blog/tag/outils/">Outils</a><a href="/blog/tag/productivite/">Productivité</a><a href="/blog/tag/solid/">SOLID</a><a href="/blog/tag/video/">Vidéo</a>
    </div>
</div>
</aside>		</div>
	</div>
</div>

	<footer class="main-footer">
    <div class="container">
        <div class="footer-bottom">
            <div class="row">
                <div class="col-sm-12 col-sm-pull-12">&copy; 2021 <a href="https://itexpert.fr">IT Expert</a>. Tout droits réservés.</div>
            </div>
        </div>
    </div>
</footer>

	<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>
    <script src="/assets/js/bootstrap.min.js?v=c68fe2808e"></script>
    <script src="/assets/js/plugins.js?v=c68fe2808e"></script>
    <script src="/assets/js/main.js?v=c68fe2808e"></script>
    <script src="/assets/js/wikipedia-excerpt.js?v=c68fe2808e"></script>

    <script type="text/javascript" src="/assets/js/prism.js?v=c68fe2808e"></script>

    <!--
<script>
    var MailingListURL = "https://app.convertkit.com/forms/1516508/subscriptions";
    var NameInput = "email_address";
    document.querySelector("#mailinglist-subscribe-widget")?.setAttribute("action", MailingListURL);
    document.querySelector("#mailinglist-subscribe-input-widget")?.setAttribute("name", NameInput);
    document.querySelector("#mailinglist-subscribe")?.setAttribute("action", MailingListURL);
    document.querySelector("#mailinglist-subscribe-input")?.setAttribute("name", NameInput);
</script>
-->
<script src="https://cdnjs.cloudflare.com/ajax/libs/tocbot/4.12.0/tocbot.min.js" integrity="sha512-oD3xGN8YTxenx6tdS4D/RKqO4OtORBQtAb2/FseM17GGMIi6jMwKUBc8duX4A5RwMOGGXoFBZrsqbOk8GpXFgQ==" crossorigin="anonymous"></script>
<script src="https://ghostboard.io/t/5f1349d76929c0037583f152.js" type="text/javascript" async></script><noscript><img src="https://ghostboard.io/api/noscript/5f1349d76929c0037583f152/pixel.gif" alt="" border="0" /></noscript>
<script>
    tocbot.init({
        tocSelector: '.toc',
        contentSelector: '.single-post-entry',
        headingSelector: 'h2',
        hasInnerContainers: true
    });
</script> <script async data-uid="6ccc22cd69" src="https://itexpert.ck.page/6ccc22cd69/index.js"></script>
<script>
    let ck = "6ccc22cd69";
	let links = document.querySelectorAll("[href='https://itexpert.ck.page/" + ck + "']");
    links.forEach(element => {
		element.setAttribute("data-formkit-toggle", ck);
	});
</script>
</body>
</html>